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learn.r-journalism.com % 1 Z& L 1
Syntax

R ZHERE S B 51213, B 2 SCHANCAED 2T R 0 $8 A, RIIMETEEEA,

e RIX (SQL &EIFHEARY) KXFTL/NLTEXBIL, (CLEHST) A& T XRISFETT,
o FulFh>hbavwl REANTEET,



o I RALMOFNTIE #EANTLZEN,

o AV NMNINAEBDONIZEZNDEIITHENEL X9,

o ZDI—ATHLEFWET,

o AT—RAV I, BEESAT V=2 bOBIY B TREERRT D a2— FTTT
(HATLFLL) a—Fo@RPTo 2=k Ians 2 ANT5E, BRI LNET,

U—X%v 754V 7 MY

7~¢y7?yy&ﬁﬂ@\ﬁﬁ%%bfwé:yﬁl~ﬁi®7jwﬁﬁﬁo%6774w§%<;
WCERT D E, FOT7ANDIT =X TFT 4 L7 ) ERHRNEST, T—F 7 7 A VR ERFET
éi?R ERTDHE, U= T o7 PUIIRFELET,

EEZBIIRT HDRICIE, TRXTOT—F AT VT N7 7 ANABREENTWEIEFRZ TV —F 75 4
L7 R ELTERELTLEEN,

Tip:

ZDUTAT, WENBVEDIZaZ— RS 2551F, BICRBEIZWRY RTEOaI— FEZEITLT
&, aY—ATHEITTHZLEHLTEETN, BEZEIDLIICAZ VT NEHESONREEL
WEBEWET, EFATIE, ar Y= 27 Y P ROEITERLTCa—F o2 LET, 2
I—RELroERALTWEDN, TNELEEZEZTRVMDONZ L > TR £, LT@IZ, =
U=V TET LT —FEZ2 A7 Y Mabt—&X—A T HZLICRD5TLEY, F/2, o~ R
DR LTEGA O IFEICET e v el BIOPIRA#HEZEELETOT a Ay Ty v Eh
fea— R FHmATIEEN,

HE, V=X T4 b7 N BEFETERET D HETT,

# Mac 72 5 setwd("~/projects/learn-r-journalism")

# T DM D pc /7 setwd("C:/Documents/learn-r-journalism")

Note: X7 v L aNEWMD AT v 2aThDHI LD, T L THIHAFEENRNEIICLTLES
W, RStudio Ti&, U—F > 77 1 L2 b U &ZA=2—7D Tools > Set Working Directory &5 FIET%

ETEET,



File Edit Code View Plots m Build Debug Profile Tools Window Help

(‘ [ NON ) | New Session | ~[Projects/learn-r-journalism - |
e - OR‘ & - = : jAddins -
iitial_exploration.Rmd @] 2018—05} Terminate R... %o—to—r.Rmd vo| _index.en.md
A 1B 1H 1V R 18 RestartR tragroPlnser - | & O | EWRun - [ 4
26 i " RestartR and Clear Output I ’
27 Restart R and Run All Chunks

28 {{% notice note %}}

0Ll Make sure that slashes Set Working Directory > To Project Directory

is also case sensitive, ' To Source File Location
30 {{% /notice %}} Load Workspace... To Files Pane Location

31 Save Workspace As... ‘

32 | Clear Workspace . | Choose Directory... ~{'H
33 Within RStudio, you can \a the menu *Tools > Set Workii
2 Directory* Quit Session...

ERED =~ B setwd ()Tt S 2 DORERI T,

BV IS IR AETN, AHORD S LA VT hadFLiznegh, Jloarva—2Ta—R
EEITLTRAFLIZVWEERSTYH, iR 7 ) F ERENNIZ 2 Ea— X OMIZIZFE LR N T 41
EREZRRE D ET20T, SELWPRVTLE S, ZHEFHIMEOBANLT 5 LHANTIESH
D EHA,

T—X% 77 4 L7 NVITERES T, F6ECREOFEEZMNMLETH, ZLYTEV DY 7
(https://wangfanghelsinki.wordpress.com/2015/03/31/understanding-and-setting-rstudio-working-
directory/) # ZHE < E &V,

FA477Y

RIZSFIERT—FHEOIZTO ZENTEET, TNHIEFVDYDL Ny =R F 77T Ve L
TELOLATVET,

RIZTZAT TV BNl TH, ORI EITH ZENRTEET, Tz baseR LIFUET,

LrL, ZOMIZHROMME T RO RMEZFRT 27477V 2EY £ LT, RNy TF—V0OF]
MEZ, ThEho7n Y= MNIBRERIAT7I VT aF v rn— FLET,

A UVAR=LENTWNWETRXRTONRy =0 A MEEETDI0E, Ny r—Y 0 0 RUICBEd
D, Ay = llibrary()) EANLET, RN r—Y U4 U RUT, Ny —CAOMICTF = v 70
AoTWBEGAE, BRIy r—Ue— K&, £OFOREE FRHTHEFNA TE TV ET,

R®D Web A MZlx, XV Z DR —URHN ET, RN —T% A A M= /L LTHENWZWEGES
(7= & 2T "dplyr" 72 5) -

o Nulr—U% A A M—/L: install packages 27 U v 7 L, /Xv 7 —I 0 42 R dplyrt & AT
B, 3 —/V T install.packages("dplyr") & T HIAA TL 72 &0,

o Ry —VOXFT s u— R dplyr ORTOMIZTF = v 7 2 A h, 3 Y —/uiZ library("dplyr") & A
HLTLTESNY,



Ra<r FoH

A

RIFEBEHE L THEXET,
SO%ICar Y=y 4 R EANTHETTY,
Note:Z D& 7 o g T, #1ftW\W-a— RiZ EDofToa— FOHHEZEW L £,

1072 + 26
##[1] 126

J— AR—2R

Bzt L b TEET,

ZHOLTRIFE BTHEATES, WOWLIERIZRDDTTY,

a<-4a

#[1] 4

QEEIRICHED ZENTEL LTV E L,

a*5

##[1] 20

RDEFORET DL, B S TR G RN o772, LA > TWEIERFF SN TV EH A,

a

##[1]4
AIOMEZMER L Ta IZH LUVWMEZRAT L2 L b TEET,

a<-a+10a

H##[1] 14

RDOAEYNHTNTOELZHIRT 5121E. ROLIITATILET,
rm(list=Is())



FE, V=T AR—=ZAD "dearall" 7 U v 7 LET,

Environment History Connections Build Git — ]
<2 [ | 2 Import Dataset ~ | & List ~ | @

Global Environment ~ -~
S - Clear objects from the workspace |

Data

© data 10 obs. of 3 variables
© new_df 3 obs. of 4 variables
© test 10 obs. of 3 variables

RI]T—EXT h v

%< DT T T LAERBRIZ, R 1IHE XV 77— (KREEDHBEESORTDOE), X7 fa (BH), B L
HFENET) , 77A(SITEAY LERFANCHFELET, BIFEER L@ AL T—TT,

3, 4, 5 EWVIOIHEMNBR LN MVEERT DI, EiE (LT EDED) OIETHD o) &5
BPBETT,

b=c(3,4,5) b

##[1]345

B%k
FROFITHEITT2~T RV b OFT R CTOEREDOEEZFHE LWGEIE, RO L IICATLET,
(3+4+5)/3

#i[1] 4
LorL, BV "7 b e, ZIUTIERITIHEEETT,

BT T — 2 2T 572D b DT, RIZBEFTHEREINTWET, “median() < summary() ® KL 912,
HébhERIMBLTOWAMEEDLHIE, 1B LISy r—2 0 —fE L TRIESNTWIEELH Y F
R

TR RS 28, ROX S AT LET,



mean(x=b)

##[1] 4

O W& gd/#xe AnET,
SIEUIREEIEMOER A EZ 20 TT, 22Tk, I8, EHEZEHEL LS L LTV
DES (7 bV) ZRLET (T72Dbb),

FBOLBIPAERGEELH Y £

mean(b)

H##[1] 4
I THRLILITT,

7ry bk

RIZBHRFICI e 7T 7 4 v VHAED ZENTEET,
#rnorm() I, T2 KX ALRGHTIE VT E LTS B T,

distribution x <- rnorm(100)

# plot() /Z plot(x) & 7+ — FMZT S BIETT,
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e 141TH TIX, 100 fEHDOELLEMN T b & L TEE X IZEY ¥ ToET,
« TATHE, 2TOMET 0y by 42 FUICHiE LET,



A7 YZF B

RIZa~y RIA U R_R—ADEEAHEHTHA 027V HTT, DF0, ~UARLA=2—%EH+T5D
TIE2<, a~r FEANTAHELERHLLZOTYT, ZHZIE, T Lba~vy FEFEATTIHHLEN
WEWIFIENRH Y 9,

A RET77A0, WbWLE X2 Y I MNRAFETLHIENTEES, ZNUHLDOAZ Y 7 MIEHE,
script.R D L D IZ.R E WO ILIRTF PN 7 7 A VA EFF L E T,

File > New ¥ 721 File > Open file..7" 5 ZIVHD 7 7 A NV EfREST H 2 LN TEET,

17% 34K L C CTRL+ENTER 7> CMD+ENTER . A7 UV F v T 4 XU 4 RUD E¥IC®HD Run 27V v 7
THE, = RO—HEFRIT (2 Y —NU 4 FUIZEE) TEET, MHERLRTE, RITV—
INNHDHITEFEITLET,

WO T source() X IEA 2 ) 7 MR EEITTEET,

B 2L, AREHEHD seriptR BMEET 4L 27 FUDAL— T4 L7 RUIZHY, 207 Y 7 M kr3E
1T 2%A 121X

source("script.R")

TF ¢ A 42 R T Runall 337>, CTRLSHIFT+S £ 721X CMD+SHIFT+S & AJ1 L THIEWE R A,

FAETER2WVWT—#

HERIZT = 2® o L&, FHUINRKBR LI A= 7 =R A Lo, LIFLIEEAXRELTHD
ZLEBHY ET,

T =AY TELZ2GEEIZE, BFORDVITNAE KL T 2LERH Y £,

j<- c(llleA)
B WA, RERRT =2ty FOREE LD 2 LIFARARETT,

HRT-NHEL TV o RO KDEEZRESELIHEEERN LT b LNLETA, LN
ST RIL OERKENMTISNHERNERTTL L I,

max(j)

## [1] NA

RIFTTWDT—XIHEDTEE LTZWEAIE, 512 na.rm=TRUE® ZB1 L 9 (FE T HITNAZFRA L £
T2 Yes VD Z LT,

max(j, na.rm=T)

#i[1] 2

Warning: NA (35 5 55 HRICHE L £,
sum(j)

## [1] NA



# compared to sum(j,
na.rm=T)

##[1]3
NA ZALERT A7 DN DD Y 7 % TR LET,

7 p

INFETITEEZE->TEE Lz, UL, b0 95 T —# 121, XFX° TRUE £7213 FALSE &\ o
77—, BRREOTFIHIO LI, thobDobHDHDTY,

prac2

m <- "apples"
m

## [1] "apples"

XFHNTHDHZ L% RICIEHEI T, sIHFOMICT XA NE AT LHIMERH Y 7, £ 95 L
L. RIFFICARIOERBFAELREZHR L TLENET,

n <- pears

## Error in eval(expr, envir, enclos): object 'pears' not found

WFEM->CHETLZ LT T ERTA,

m+2

## Error in m + 2: non-numeric argument to binary operator

HfF

FAT & B IAHE S T R, 3EFAS 2BF 59 0DRITHKD Z &, T L T2 AIRKFIC—E 29 B d
5 &S TWRITNIEZRY A,

AT ERZOMAEDETHD 2 & & RIUB A D AR R TTIEL strptime() BIE 2 5 = & T,

datel <- strptimel(c("20100225230000", "20100226000000", "20100226010000"), format="%Y%m%d%H%M%S") datel
## [1] "2010-02-25 23:00:00 EST" "2010-02-26 00:00:00 EST"

## [3] "2010-02-26 01:00:00 EST"

BB () I L » TR MADMER S L, SIAMFOM OB TFIIXFHE L THRbIVET, T strptime()
RIH A D 72 DI LB B E T,

SN DOFEITT EBET D 5 format N EIZHENTWET, Z OB TIE, F(%Y). H(%M). F(%S)DIIEIC
WATHET, 73—~y bR A MY UG L TWIUIE, £TEIEETAHETH Y THA,

Z D —ATiX lubridate Ny 7 — TV EFEH L CFEEEZNTTICEMNZLE T2 HEEER L ET,



#lubridate #N» o —28 4 R f— L L TRV EIE, LLFDIFD I X &g L TEITL TS 2S00,

# install.packages("lubridate") library(lubridate)

HH
## Attaching package: 'lubridate’

## The following object is masked from 'package:base':
HH
H# date

datel <- ymd_hms(c("20100225230000", "20100226000000", "20100226010000"))

ymd_hms() 1Z. A RY S ZHNOE, B, HERE, 4, B2 LET, [ 3 =](http://learn.r-
journalism.com/en/wrangling/dates/dates/) CX W L < B L 9,

S

C AU o T

* (MRl E D) AFRNESL B2 ED) NAFFRE Z2 08 TERT — 2 LW, 207 — X ik 2 AL
THEE RICERLET,

*ETHEELBRICHELL T, LU S TWET,

* MBS ETINERREOZHITER ., KNTL LTI E T,

el ZE, AfEZ TAAL, TRAL Tex =y EANTDHELELE D,

Ay R— b EDT—EE2AVR— T 55L&, RIZSDI ZNERF L LT LET,
UTFDOa—KREEITLT, LA 7 V=7 b sample_df L) T —H% 7 L—A%E{ED £97,

sample_df <- data.frame(id=c(1001,1002,1003,1004), name=c("Steve", "Pam", "Jim", "Dwight") age=¢(26, 65, 15, 7),’ )
race=¢("White", "Black", "White", "Hispanic"

sample_dfSrace <- factor(sample_dfSrace) sample_dfSid <-

factor(sample_df$id) sample_df$Sname <-

as.character(sample_dfSname)

- A " Filter
“lid name age race
1 1001 Steve 26 White
2 1002 Pam 65 Black
3 1003 Jim 15 White
4 1004 Dwight 7 Hispanic

R LT — 2 7 L —AOEER R TAHAE L L 9,



str(sample_df)

## 'data.frame": 4 obs. of 4 variables:

## S id : Factor w/ 4 levels "1001","1002",..: 123 4

## S name: chr "Steve" "Pam" "Jim" "Dwight"

## S age : num 26 65 15 7

## S race: Factor w/ 3 levels "Black","Hispanic",..: 313 2

RISABE = 2D LSS 5 R RIZHTIZ LR L T T
levels(sample_dfSrace)

## [1] "Black" "Hispanic" "White"
CHEIRDZOMHE ZODL LTI N—TbT 52 L2 RLTOET,
summary(sample_dfSrace)

#Ht Black Hispanic White

#it 1 1 2

ROWETIE, SCFFIZT A7 7 Xy MECEREL 2. BEO3ICED S TEF, 1=BA, 22k /5=
Y 3=AALNS ZEICRD T, TREMB D ERREEREROTL L D b

Uy —F VA MIRFEHMBETDLZLICHEY LR LIXUIRKETF 2 CFF0LFICE E #ix T
WET, L, BEURET AV EER LIV E W I BRICETRERELE S, R 2@ Rko—>L L
THEA D Z LBARNZRY 9,

Tip: 2D X 972 R O HEE LNV T, R BRHEHFEEIC L - T, HHFEEDOTDIHER SN2 &l
ERTHEDOTT, RIZKELSHEEL, FIAEDaI 2=T 4137 — 42 ERBE LA HETHY Lo
WALIHTEELE, Ll BELAZEZWEDOWS ONELELELLAETE S TWVWHEDTT,

B LHT
FREICHA T OB E T 10 ERTT, RIBEFVRIET D= M2 MK
DT ENTEERA, & XIE, Tain) 124 TRARIFHIE LTRbUET,

F— Z R DI
UTOEIZEELTLIEE N,
o WTEIFINEBRTHLENTEET,

sample_dfsrace

## [1] White Black White Hispanic
## Levels: Black Hispanic White

as.character(sample_df$race)

## [1] "White" "Black" "White" "Hispanic"
o WITFHNERFICEWTHZ L ETEET,

sample_df$name

## [1] "Steve" "Pam" "Jim" "Dwight"

10



factor(sample_dfSname)

## [1] Steve Pam Jim Dwight
## Levels: Dwight Jim Pam Steve

o NFZEUHICEHS 52 LITTEERA,
sample_dfsid

## [1] 1001 1002 1003 1004 ## Levels:
1001 1002 1003 1004

as.numeric(sample_dfSid)

##[1)11234

RIZAFZEE L L THNT 20006 T, BIEICEIT 511X F ISCFTEBR L 2T 0 £8 A,
ZIHTIURX, RA RDBAREIZAR Y £,

sample_dfsid

## [1] 1001 1002 1003 1004
## Levels: 1001 1002 1003 1004

as.numeric(as.character(sample_dfSid))

## [1] 1001 1002 1003 1004

Tip: IROE 7 2 a IR RICHMGE LR THRLRTT, FPOSEELRRNAETT, EEEOREILTL,
FEHRAL

B HES
T AR WL T 5701, o — FEBERICRET S 2 b TEET,

percent_change <- function(first_number, second_number) { pc <-

(second_number-first_number) /first_number+*100
return(pc)
} percent_change(100,150)

##[1] 50
EFiRoa—RKE2FTTHE, ZARZEDRERE T

* percent_change 3B DA HI T, “function() BN Z BV Y THENTWET,
* first_number & second_number &\ 9 " ODELMNNIEE T,
FT ATV 2 Mpcld, I 2 DOEH D — NELEFE L TER SN E T,

* “return()' (X percent_change’ |ZFtRAERAIRLET, 29 LTI Ny r—
2] (https://github. com/andrewbtran/muckrakr) & U CIRETE £,

BEIZOWTKERZ LIIENONAMICE ST R T AINTNDH LN ZETT,

11



ZOBBEERTELDE, AR oLl ZRENNEET, HFARE-TNDH I E2H -
TWLPHTT, ROEETZ I =R ELIELEIE. TORBREICEL TWE D72 &b —D2DICH
R D D AREMED BV £,

‘percent_change() BB CFANEET L Z 5720 £,

percent_change("what", "happens")

## Error in second_number - first_number: non-numeric argument to binary operator

This is the point:

BENTZROT R TF~v—1X, HOELPUOAMEEIRANCL DT —2THEL T, ORI —RROR
DOICEINESREEZ NN THTL LY, FEOZTI—ITbEVHATELY A, =T — %R
2T TN E LSBT D2 DICHF RV ERZ 2o TWET, LrLEHiLna—F—i3%
NEMLRWVDNE LIVER A, ZHUL, HRTENBEEPHEE LW e XIE L5 & ERITTT,

T 7 —% Google THERT 57>, 22— FEBHNWT, =7 —DRKREZMHRTE 5008 20, £7IFBREEKIZT
BEE LT —RNRETDORERN D0 E D el LET,

I bPha—T 4 7 LTHOANEIEAELTNDEE, MO ANBES THA ST XTOHEZTHIT S
ZLETEERA, BEOIEREICRA v =T REDID, Ny b=V EFENEGEIIMO NN DT 4
— K8y 7 il <& T

ZOHMABNRRAI 2=T BT HIEE2LETHHRFOL LWHDIZLTWET, B biddEx Bk
LTWHDTY,

E

[78 & (http://code.r-journalism.com/chapter-1/#section-intro-to-r) Tk Z HIZ>TEL X 9,

T YA XT T DOETHFIECETIHAEZ., 2ok T > a D #I<— (http://learn.r-
journalism.com/en/how_to_use_r/) IZ&H U F 77,
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